Keith & Koep GmbH 27. February 2006

Trizeps4 and ConXS
Quick-Start-Guide

Version 1.1

This document guides you through the first
steps of using the Trizeps4 running on the
ConXS-Evaluation-Board.

1.0

Introduction

2.0

Thank you for purchasing the Trizeps4&ConXS-Evaluation-Kit.

The Trizeps4 is a small and complete SODIMM-size computer. Everything for a
fully working module, like Flash-Storage, RAM etc. is already included and only a
power-supply of 3.3V is needed to run it.

The ConXS-board is designed as motherboard for our SODIMM200-Trizeps-Mod-
ules. It contains several interfaces, and is a good starting point for your own prod-
uct-design. A ligth-version of the ConXS-Board is availlable for use in your
products.

Technical documentation can be found on the CD coming with this Evaluation-
Board and on our FTP-Server [see chapter 4.6]. Sign the Non-Disclosure-Agree-
ment [CD::\Board Doc\DesignKits\ConXS\nda-conxs-englisch.pdf] to get addi-
tional information, like schematics and VHDL-code.

Support:

Hardware: hardware@keith-koep.com

Software: software@keith-koep.com

Sales: sales@keith-koep.com
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Evaluation-Kit Contents

1. Trizeps4-Module

2. ConXS-Board with display

3. Power-Supply

4. Serial Null-Modem-Cable, USB-Cable

5. CD containing WinCE-Board-Support-Package, Tools and documentation.
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2.2

2.3

Using the board

Normally the ConXS-Evaluation-Board should be assembled and ready to use. All
you must do, is to connect the power-supply to the ConXS-Board and wait till the
pre-installed WinCE-image boots up.

If the SODIMM is not fitted with a Trizeps module when you receive your board,

follow the next instructions:

1. Slide the Trizeps into the socket taking account of the polarity mark. Do not
touch the gold contacts. You can see that there is a polarization mark cut in the

Trizeps ; this ensures that the module is adjusted correctly. Put the Trizeps mod-
ule carefully at an angle of about 30 degrees into the socket.

2. Support the underside of the board and push the Trizeps down into the socket. It

should click into its place.

Using the bootloader

The bootloader is the ,,BIOS* of the Trizeps-module. It decides what to boot and
may assist you in testing your hardware.

To enter the bootloader-command-interpreter:

1. Connect the ConXS-board with a serial null-modem-cable to your pc.

2. Open Hyperterminal with 38,4kBaud, 8 data-bits, no parity, 1 stop bit, no flow
control.

3. Press ESC and hold it pressed while turning on the Evaluation-Board.

4. Take a look at the supported bootloader-functions: ,,?*.

TABLE 1.

Often used Bootloader-Commands

Command Description
? print supported functions.
tftp load file from TFTP-server.
ereg erase permanent registry ( recommended, before loading

a new WinCE-image).

eflasb0 erase everything from flash, except the bootloader.
epsm erase persistant-storage (Flashdisk-folder in WinCE).
mount mmc or mount storage card. This must be called, before you can
mount pcmcia use the card.
cd, dir navigate through the directory structure of a mounted

storage card.

boot mmc <file> or | load a file from a storage card.
boot pcmcia <file>

fb flash boot. Boots image stored in flash.

contr, backlight adjust contrast or brightness of a connected display.
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Loading files

Files loaded from the bootloader must contain a bootheader (;view
[CD::\MT6N_BSP _CD_2.10 _05\Bootloader\KuK\Doc\bootloader2 02.pdf] for
details.). The bootheader describes what to do with the data appended to it. Typi-
cally the bootheader describes where to store the data (program code) and if to jump
to a specified address in RAM or FLASH to execute this code.

Examples for loadable files:
*  WinCE-Images:
[CD::\wince500\mages\CONXS\TRIZEPS-IV\Im8v31]
+ Boot-Bitmaps (Bitmap shown on boot):
[CD::\MT6N_BSP CD_2.10 05\Bootloader\KuK\bootblock\BitmapBoot]

The bootloader can load files from various locations:

 Ethernet using a BootP/TFTP-Server running on your PC.

» SD/MMC-Cards (formated as FAT12/16/32).

e CompactFlash/PCMCIA-Cards (formated as FAT12/16/32).
 Using additional programs, like EBoot.

Loading files using Ethernet
To load a file through Ethernet, you must set up a BootP/TFTP-Server:

1. Download boottft.zip from our FTP-Server [ftp://www.keith-koep.com/pub/
bootloader/BootTftpServer Windows].

. Unpack and install Cabletron tftp/Bootp-Server.

. Connect Evaluation-Board with Host-PC (Ethernet and serial connection).

. Open Hyperterminal and enter the bootloader-command-interpreter.

n A W N

. Clear registry: ,,ereg®. This is extremly recommended for every new image you
load. Old registry-settings may result in misbehaviour of the system.

6. Obtain MAC-address of the Ethernet-Controller: ,,mac®. This will print the cur-
rent mac-address. If you wish to change this, enter a new one, else press ESC.
(All Trizeps4-modules with Ethernet-Controller have an unique MAC-address
shown on the label).

7. Start Cabletron TFTP/BOOTP-Server. Choose BootP-Tab and enter Ethernet-
Address, a free IP-Address, and the place, where your image-file resides. Push
,Update“. Note: The MAC-address must use ,,-“ seperators (i.e. 00-50-C2-0E-
CD-12). You must have ,,Broadcast Reply to Bootp Request™ selected.

8. Type , tftp“.

9. Wait till upload finished. If you loaded a RAM-Image (nk ram.nb0) it will start
automatically, else (if ROM-Image (nk_rom.nb0, nk zip.nb0)) type ,,fb* to start
image.

Loading files using storage-card-interface

To load a file using a SD/MMC or CompactFlash-Card:

1. Copy the file to a SD/MMC or CompactFlash-Card.

2. Insert it into the ConXS-Evaluation-Board.

3. Type ,,mount mmc* or ,,mount pcmcia“ to mount the card.

4. Type ,,boot mmc <filename>* or ,,boot pcmcia <filename>*.
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5. Loading should begin.

. Copy the file to a SD/MMC or CompactFlash-Card:
. Rename file to autoboot.000.

. Insert card and switch on power of the Evaluation-board.

BOW N -

. While booting, the bootloader will check if a file named ,,autoboot.000* exists on
a connected storage-media and will boot it. After autoboot.000 has been loaded,
the bootloader will check if autoboot.001 to .999 exists and boot them in this
order.

Loading WinCE-Images using EBoot

EBoot is a common used ,,Bootloader” for WinCE-Devices. As we provide our
Trizeps-modules with an OS-independant bootloader, our Eboot is just a small pro-
gram, which is started by the bootloader. The source of this program is located at
<WINCEROOT>\Platform\TR4CONXS\SRC\Bootloader\Eboot. After building
the platform, you will find two loadable eboot-files in your FLATRELEASEDIR (
Build OS-> Open Release Directory):

¢ eboot.nb0 ( RAM-Version)

+ ebootrom.nb0 (ROM-Version)

You can load Eboot through ethernet or the storage-card-interface, as described in
the previous chapters.

Example of using Eboot:

1. Copy eboot.nb0 to a SD/MMC-card and rename it to autoboot.000.

2. Insert this card in the ConXS-board.

3. Open your project or the nk.bin (WinCE-Image-File) with Platform-Builder.
4. Target->Connectivity Options:

Select Download = ,,Ethernet and press Settings-button next to this entry.

9]

. Turn on power and wait till a device name appears in the Settings-box.

6. Choose the apearing name and close ,,Target Device Connectivity Options“-dia-
log with ,,Appy*“.

7. Target->Attach Device
Download should now begin.

The WinCE-Image will be copied to RAM, starting at 32MB. This is different to the
behaviour of the bootloader. The bootloader will load a WinCE-Image (nk_*.nb0)
to the end of memory. This is important, because everything before the WinCE-
Image will be mapped as usable RAM. If you have a Trizeps-module with 64MB-
RAM and a WinCE-Image with a size of 12MB, than 52MB free RAM will be
reported, if you use the bootloader and only 32MB if you use Eboot. To change the
starting address, where eboot will put your image, modify

EXECUTABLE PHYSICAL in mt6_io.inc. ( You will need to rebuild Eboot).
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3.2

The WinCE-BSP helps you in creating your own custom WinCE-images. Prebuild
WinCE-Images may be found at [CD::\wince500\Images\CONXS\TRIZEPS-
IVAIm8v31] or on our FTP-Server [see chapter 4.6].

Installing the Trizeps4 Board-Support-Package

You will need Platform-Builder 5.00 from Microsoft ( free Eval-Versions are availl-
able) and our BSP [CD::\wince500\BSP\BSP TR4CONXS yyyyQx_ z.msi].

First install Microsofts Platform-Builder, than run the BSP-install-file.

View the release-note to the BSP found after install at [c:\wince500\plat-
form\trdconxs\docs\]

Creating an image with existing project CoreMax

The CoreMax-project is a good starting point for an own custom-project. It includes
almost all needed components and may still be licensed under Microsofts WinCE-
Core-License.

1. Copy and unzip
[CD::\wince500\PRI\PRJ] COREMAX TR4CONXS yyyyQx.zip] to
[e:\wince500\pbworkspaces\]

2. Open the CoreMax-project through:
File-> Open Workspace...

3. Choose to build a release-build:
Build OS-> Set Active Configuration...

4. Build a WinCE-image ( this will take 20 minutes to up an hour) :
Build OS-> Build and Sysgen...

5. The build process should finish with no errors and some warnings.

Note:

If no errors occured, the build process runs makeimg.exe. which will create a nk.bin
file in your FLATRELEASEDIR ( Build OS-> Open Release Directory). This file
is not the binary image. After nk.bin is created, PostMakelmg.bat will run. This
batch will create 3 binaries, patched with a bootheader ( see
[CD::\MT6N_BSP_CD_2.10 05\Bootloader\KuK\Doc\bootloader2 02.pdf] for
further details).

« nk ram.nb0 Image will be loaded to RAM and execute.
e nk rom.nb0 Image will be stored to flash (uncompressed).
» nk zip.nb0 Image will be stored to flash (compressed).

The maximum size for a WinCE-image build with this Board-Support-Package is
32MB.
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Creating an image from scratch

. Choose File-> New Platform.

. Push Next.

. Choose TR4ConXS and press Next.

. Select a configuration (i.e. Industrial Controller).
. Push Finish.

. Choose Build OS-> Build and Sysgen...

. Wait till build finishes.

N N N R W N -

Note:
(View notes from 3.2).

If a component added is excluded from build (red-cross in the right corner of the
icon), you get the reason by pressing the right-mouse-button on that icon and choos-
ing ,,Show why item is Excluded from image...““. RightClick on the catalog, choose
,Find*“ and search for the missing item. If the reason is a PLAT xxx-variable, you
have to remove or set it in the [% WINCEROOT%\TR4CONXS\Cus-
tom\TR4CONXS.bat].

Sometimes drivers need additional components from the Microsoft Platform-
Builder to function as expected!

» To use Compact-Flash storage cards, include the ATADISK and the FAT-Filesys-
tem component.

» To use a SD/MMC storage card, you have to include tha FAT-Filesystem compo-
nent.

» To use Active-Sync, you have to include ActiveSync and the Network User inter-
face (SYSGEN_CONNMC):

SD/MMC: add ,,SD Memory“ SYSGEN_SD MEMORY

USB-Slave: add one of the USB-Function clients (RNDIS,
Serial(ActivSync), Mass Storage) (i.e. Serial: SYSGEN_USBFN_SERIAL).

Wave driver: add ,,Waveform Audio* SYSGEN_AUDIO.

Known Issues:

If you want to use the UCB-Touch driver, always include the Wave driver. Other-
wise the system may hang after suspend/resume!

Debugging with Platform-Builder

Platform-Builder may connect to your device with the ,,KITL“-interface (Kernel
Independant Transport Layer). KITL uses Ethernet and can be activated dynami-
cally on retail-builds, by passing ,.kitl“ to the commandline of the bootloader (
;must be newer than 27.02.20006): ,,fb kitl“, ,tftp kitl“, , boot mmc eboot.nb0 kitl*
or is activated automatically when using debug-builds.

For a KITL-connection, you must open Target->Connectivity Options and select
,,Ethernet as transport. Press the Settings-Button next to the listbox. Start your
WinCE-Image and wait for the device-name to appear. Select it and close the dia-
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log. Press Target->Attach device. The device attaches and you should see some out-
put in the debug-window ( View->Output).

There are many things you can do with KITL and even more that you can do with a
debug-build using KITL. View Platform-Builder Help on details.

Things you can do with WinCE

4.1

4.2

With WinCE you can do almost everything, that you can do with a ,,big* computer.
Allthough a full OS can be squizzed into images with less than 32MB ( the Core-
Max-image has a size of 16MB), many interfaces from the bigger Desktop-Win-
dows can be used. Simple Applications written for Windows would also recompile
for WinCE with no major changes.

Embedded Visual C++ and Trizeps500-SDK

To write WinCE-Applications, you may use the development tool ,,Microsoft
eMbedded Visual C++* (available for free download from Microsoft). If you decide
to use this program, you should install the Trizeps500-SDK (Software-Develop-
ment-Kit) [CD::\wince500\SDK\SDK_ Trizep500_ yyyyQx.msi].

A SDK helps programmers to develop programs for a specified project/platform.
Unlike Windows, where you may assume that all given interfaces are available,
WinCE only contains a subset of functionality, which changes with the items you
include/exclude from an image. The Trizeps500-SDK contains functions from a
quite fully featured WinCE-image, but not all is included, neither can you assume,
that your WinCE-image supports all functions from this SDK.

If you build your own images using the Platform-Builder, you may create your own
specific SDK:

1. Choose Platform->SDK->New SDK...
2. Configure SDK...
3. and finally Build SDK...

When you download your application to your platform using ActiveSync, you may
get a message ,, The targeted platform Trizeps500 2005Q2 1 does not match the
connected platform. Continue?*. This happens, when the platform-GUID ( a
unique id-string) stored in the registry at [HKEY LOCAL MACHINE\Windows
CE Tools\Platform] does not match the platform-GUID stored for the SDK
([c:\wince500\programs\Windows CE Tools\wce500\Trizeps500 2005Q2 1\Prop-
erties.xml] search for the property named ,,ID*). You may ignore this warning or
change the GUID value in the registry or in the SDK.

ActiveSync Tools

ActiveSync is a tool, that helps you connect the Trizeps4-Evaluation-Board to your
development workstation. Besides the functionality you know from PDA’s or other
devices, that use ActiveSync to synchronise your phone-book or download pro-
grams, you may also use ActiveSync to debug your program or use some of the
remote tools (i.e. Remote Registry Editor). If not already installed, you can get
ActiveSync from Microsoft for download.
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4.4

4.5

4.6

To use ActiveSync, just connect the EvaluationBoard through an USB-cable.
ActiveSync will connect automatically. If not, open Microsoft ActiveSync and
choose ,,File->Connection Settings...” and validate that ,,Allow USB connections®
is selected.

If connected with ActiveSync, start Embedded Visual C++. You may now choose
between the remote tools ,,Tools->...“. To start debugging with ActiveSync, open
your project-workspace, verfify that ,,Build->Set Active Platform...*

“Trizeps500 yyyyQx* is selected and start a debug-session.

Note: On Trizeps4, USB-Host port 2 is disabled during an USB-Slave-connection.

KuK-Tools, drvlib_app.dll and the persistant registry

drvlib_app.dll is a DLL which contains many useful functions to do device-specific
things like reset, storing and erasing the registry and i2c-communication. For a doc-
umentation of these function view [%_ WINCEROOT%\plat-
form\TR4ConXS\docs\DrvLib_App.chm]

KuK-Tools is a simple program that uses drvlib_app.dll. The main feature of the
KuK-Tools is, that you can store and erase the persistant registry. If you don’t store
the registry, changed values are lost on the next cold-boot.

RotateScreen

There exist a little tool named RotateScreen, which is shown in the taskbar:
—

L]
ol

« Tap it once to rotate the screen.

« Tap it twice to open a control-panel, which lets you set the rotation-angles.

FTP, HTTP, VNC-Server

Most images include an FTP and HTTP-server. To attach to these servers, obtain the
[P-address of the connected erthernet-card (,double-tap the network-symbol in the
task-bar) and open your browser with:
 ftp://wince:secret@<IP-Address (i.e. 195.8.230.20)>

View [HKEY LOCAL MACHINE\COMM\FTPD] registry keys.

The ftp-server is configured to use the ,,\temp*‘-directory.
 http://<IP-Address (i.e. 195.8.230.20)>/ADMIN

View [HKEY LOCAL MACHINE\COMM\HTTPD] registry keys.

« Execute VncViewer.exe contained in [% WINCEROOT%\PLAT-
FORM\Tr4conxs\Vnc 4 customers\vne.zip]. You must have included the VNC-
server item to your image!

Application-Notes, Samples and Updates

You will find application-notes, samples and updates in the private part of our ftp-
server at:

ftp:\\ce500:ce500@www.keith-koep.com
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