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Getting Started with SPARK 
using Trizeps4 and uConXS   

Version 1.0

This document guides you through the first steps of using the Trizeps4 
running on the uConXS-Board.
1.0 Introduction

The SPARK Your Imagination offering combines an embedded device with Win-
dows Embedded CE and Visual Studio. The embedded device consists of a Trizeps4 
module and a uConXS-base-board.

The Trizeps4 is a small and complete SODIMM-size computer. Everything for a 
fully working system, like Flash-Storage, RAM and more is already included and 
only  a power-supply of 3.3V is needed to run it.

The uConXS-board is designed as motherboard for SODIMM200 Trizeps modules. 
It contains several interfaces, and is a good starting point for your first experiences 
with embedded computing.

The Microsoft Visual Studio development system is a suite of development tools 
integrated in a single integrated development environment (IDE). Windows Embed-
ded CE Platform Builder is a plug-in to this development system. 

Though no support is given for the SPARK-boards, Keith & Koep GmbH will host 
a Wiki at the company website ( www.keith-koep.com). A feedback-form or simil-
iar will be included, so that questions not answered by this manual may be asked.

We offer professional-services and evaluation-boards including support if you want 
to start developing commercial devices.
1 von 10



Keith & Koep GmbH Getting Started
2.0 Getting Started

2.1 Evaluation-Kit Contents
1. Trizeps4-Module
2. uConXS-Board
3. CD containing Board-Support-Package + Tools + Documentation.

4. Windows Embedded CE 6.0 R2
5. Visual Studio Professional 2005

You will need a power-supply and cables, which you may purchase as seperate kit.

2.2 Starting the board
Normally the uConXS-Evaluation-Board should be assembled and ready to use. All 
you must do, is connect the power-supply to the ConXS-Board and wait till the pre-
installed Windows Embedded CE-image boots up. You may attach a display to the 
VGA-connector of the uConXS, before powering on the device. 

If the SODIMM is not fitted with a Trizeps module when you receive your board, 
follow these instructions:

1. Slide the Trizeps into the socket taking account of the polarity mark. Do not
touch the gold contacts. You can see that there is a polarization mark cut in the
Trizeps ; this ensures that the module is adjusted correctly. Put the Trizeps mod-
ule carefully at an angle of about 30 degrees into the socket.

2. Support the underside of the board and push the Trizeps down into the socket. It
should click into its place.

2.3 Using the board
The Windows Embedded CE-Image already stored on the Trizeps-module should 
include everything you will need to get started with your own project. Windows 
Embedded CE is made up from several components, which may be selected to be 
included or not. This allows fitting images to several devices. If something is miss-
ing, you might want to build an image using the Keith & Koep Board-Support-
Package and Platform-Builder.

With Windows Embedded CE you can do almost everything, that you can do with a 
„big“ computer. Allthough a full OS can be squizzed into devices with less than 
32MB flash ( the MaxIE-project fits into 16MB (zipped), the Minimal-project only 
uses 4MB ), many interfaces from the bigger Desktop-Windows can be used. Sim-
ple Applications written for Windows would also recompile for WinCE with only 
minor changes.

The network-driver is set up to get its IP-address with DHCP. If you have no 
DHCP-server connected, you can change network settings at:

Start->Settings->Network and Dial-up Connections.
 Double-Click DM9CE1 and set your network settings accordingly.
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2.3.1 Internet Explorer 6
Surf the Internet with Internet Explorer 6.

2.3.2 Media Player 9
Play media-files (audio and video) from local storage devices or using network-
media-streams.

2.3.3 Microsoft Word Pad
Do simple Text editing.

2.3.4 Remote Desktop
Connect to your Home-PC or Server using a remote-desktop-connection.

2.3.5 Use the HTTP, FTP Server
To attach to these servers, obtain the IP-address of the ethernet-controller (,double-
tap the network-symbol in the task-bar) and open your browser with:

• ftp://wince:secret@<IP-Address>
i.e. ftp://wince:secret@195.8.230.20
View [HKEY_LOCAL_MACHINE\COMM\FTPD] registry keys for additional 
settings.
The ftp-server is configured to use the „\temp“-directory on default.

• http://<IP-Address>/ADMIN
i.e. ftp://wince:secret@195.8.230.20/ADMIN
View [HKEY_LOCAL_MACHINE\COMM\HTTPD] registry keys for addi-
tional settings.

2.3.6 Connect to the SPARK-Device with Telnet
On your PC run „telnet <IP-Address>“.

login (username): wince

password: secret

2.3.7 Connect to the SPARK-Device with VNC
Execute VncViewer.exe contained in [CD:\\tools\vnc\vncviewer.exe]. Enter the IP-
address of the SPARK-board. Password is: secret.

2.3.8 ActiveSync Tools
ActiveSync is a tool, that helps you connect the Trizeps4-SPARK-Board to your 
development workstation. Besides the functionality you know from PDA’s or other 
devices, that use ActiveSync to synchronise phone-books or download programs, 
you may also use ActiveSync to debug your program or use some of the remote 
tools (i.e. Remote Registry Editor). If not already installed, you can get ActiveSync 
from Microsoft for download.

To use ActiveSync, connect the SPARK-Board through an USB-cable. ActiveSync 
will connect automatically. If not, open Microsoft ActiveSync and choose „File-
>Connection Settings...“ and validate that „Allow USB connections“ is selected.

Note: On Trizeps4, USB-Host port 2 is disabled during an USB-Slave-connection.
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2.3.9 RotateScreen
A little tool named RotateScreen exists, which is shown in the taskbar:

• Tap it once to rotate the screen.
• Tap it twice to open a control-panel, which lets you set the rotation-angles.

2.3.10 KuK-Tools, drvlib_app.dll and the persistant registry
drvlib_app.dll is a DLL which contains many useful functions to do device-specific 
things like reset, storing and erasing the registry and i2c-communication. 

KuK-Tools (Start->Programs->KuK_Tools) is a simple program that uses 
drvlib_app.dll. The main feature of the KuK-Tools is to store and erase the persis-
tant registry. If you don’t store the registry, changed values are lost on the next cold-
boot.

2.3.11 Build your own application using Visual-Studio
View Visual-Studio Help for details.

1. Install SDK_SPARK_TR4uCONXS_MAXIE.msi found on the CD at 
[CD:\wince600\SDK]. SDK = Software Development Kit.

2. Start Visual Studio 2005.
3. File->New->Project...
4. Select Visual C++ -> Smart Device -> MFC Smart Device Application.
5. Name it mfcsample and press ok.
6. Press Next. This will select the Platforms-Page.
7. Move the SPARK-SDK to the Selected-Tab. 
8. Remove other SDK’s from the Selected-Tab.
9. Press „Finish“ to complete configuration. Press Next if you would like to do fur-

ther modifications.
10.Connect the SPARK device with USB to your workstation.
11.ActiveSync should connect. If not, make sure you got ActiveSync installed.
12.Press „F5“-key. This will build the project, deploy it to the SPARK-device and 

start debugging.

2.3.12 Application-Notes, Samples and Updates
You will find application-notes, samples and updates on our homepage at:

www.keith-koep.com
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3.0 Using the bootloader

The bootloader is the „BIOS“ of the Trizeps-module. It decides what to boot and 
may assist you in testing your hardware.

To enter the bootloader-command-interpreter:

1. Connect the uConXS-board with a serial null-modem-cable to your pc.
2. Open Hyperterminal with 38,4kBaud, 8 data-bits, no parity, 1 stop bit, no flow 

control.
3. Press ESC and hold it pressed while turning on the board.
4. Take a look at the supported bootloader-functions: „?“.

3.1 Loading files

Files loaded from the bootloader must contain a bootheader (;view [CD::\documen-
tation\bootloader3.pdf] for details.). The bootheader describes what to do with the 
data appended to it. Typically the bootheader describes where to store data (pro-
gram code) and if to jump to a specified address in RAM/FLASH to execute this 
code.

Examples for loadable files:

• WinCE-Images:
[CD::\wince600\Images]

• Boot-Bitmaps (Bitmap shown on boot):
[CD::\tools\BitmapBoot]

The bootloader can load files from various locations:

• Ethernet using a BootP/TFTP-Server running on your PC.

TABLE 1. Often used Bootloader-Commands

Command Description

? print supported functions.
tftp load file from TFTP-server.
ereg erase permanent registry ( recommended, before loading 

a new WinCE-image).
eflasb0 erase everything from flash, except the bootloader.
epsm erase persistant-storage (Flashdisk-folder in WinCE).
mount mmc mount storage card. This must be called, before you can 

use the card.
cd, dir navigate through the directory structure of a mounted 

storage card.
boot mmc <file> load a file from a storage card.
fb flash boot. Boots image stored in flash.
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• Ethernet using Windows Embedded CE Eboot.
• SD/MMC-Cards (formated as FAT12/16/32).
• CompactFlash/PCMCIA-Cards (formated as FAT12/16/32).

3.1.1 Loading files using Ethernet ( BootP/TFTP)
To load a file through Ethernet, you must set up a BootP/TFTP-Server: 

1. Download boottft.zip from our FTP-Server [ftp://www.keith-koep.com/pub/
bootloader/BootTftpServer_Windows].

2. Unpack and install Cabletron tftp/Bootp-Server.
3. Connect Evaluation-Board with Host-PC (Ethernet and serial connection).
4. Open Hyperterminal and enter the bootloader-command-interpreter.
5. Clear registry: „ereg“. This is extremly recommended for every new image you 

load. Old registry-settings may result in misbehaviour of the system.
6. Obtain MAC-address of the Ethernet-Controller: „mac“. This will print the cur-

rent mac-address. If you wish to change this, enter a new one, else press ESC. 
(All Trizeps4-modules with Ethernet-Controller have an unique MAC-address 
shown on the label).

7. Start Cabletron TFTP/BOOTP-Server. Choose BootP-Tab and enter Ethernet-
Address, a free IP-Address, and the place, where your image-file resides. Push 
„Update“. Note: The MAC-address must use „-“ seperators (i.e. 00-50-C2-0E-
CD-12). You must have „Broadcast Reply to Bootp Request“ selected.

8. Type „tftp“.
9. Wait till upload finished. If you loaded a RAM-Image (nk_ram.nb0) it will start 

automatically, else (if ROM-Image (nk_rom.nb0, nk_zip.nb0)) type „fb“ to start 
image.

3.1.2 Loading files using Ethernet ( Eboot)
This procedure can only be used for Windows Embedded CE images (nk.bin). See 
„Using the WinCE Board-Support-Package“ for details.

3.1.3 Loading files using storage-card-interface
To load a file using a SD/MMC-Card:

1. Copy the file to a SD or MMC -Card.
2. Insert it into the uConXS-Board.
3. Type „mount mmc“ to mount the card.
4. Type „boot mmc <filename>“.
5. Loading should begin.

or

1. Copy the file to a SD/MMC (note it should not be longer than 8 characters).
2. Create a file on the SD-card named autoboot.bat.
3. This file can have bootloader-commands like „boot mmc <filename>“. Where 

filename is the name of the file to boot.
4. Insert card and switch on power of the board.
5. While booting, the bootloader will check if a file named „autoboot.bat“ exists on 

a connected storage-media and will boot it. 
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4.0 Using the Windows Embedded CE Board-Support-
Package (BSP)

The Windows Embedded CE-BSP helps you in creating your own custom CE-
images. Prebuild CE-Images may be found at [CD::\wince600\Images] . Prior to  
installing the Board-Support-Package, you will need to install Visual-Studio-Pro-
fessional 2005 and Windows Embedded CE6.0 R2 Platform Builder.

4.1 Installing the Trizeps4 Board-Support-Package
The BSP contains platform-files ( tr4uconxs) and three projects ( Minimal, Core-
Max and MaxIE). 
Copy the tr4uconxs-directory to <WINCEROOT>\platform\tr4uconxs. 
Copy the three projects to <WINCEROOT>\OSDesigns.
[ WINCEROOT = <Windows Embedded CE Installation path>\WinCE600 ]

4.2 Creating an image with an existing project
To give you a good starting point, we’ve included 3 projects with this BSP.

• Minimal
This is a minimal configuration, including all components needed, to use all 
of the uConXS-Board interfaces ( VGA, UART, SD/MMC, etc.).
[Windows Embedded CE 6.0 Core Run-Time License] 

• CoreMax
This is a typical configuration. It’s a good example of what features are 
still part of a Core Run-Time License.
[Windows Embedded CE 6.0 Core Run-Time License]

• MaxIE
This is a full-featured Windows Embedded CE 6.0 image, including Internet-
Explorer and Media-Player. And yet it does not include all 
Windows Embedded CE-components.
[Windows Embedded CE 6.0 Professional Run-Time License] 

To open one of these projects double-click the Microsoft Visual Studio Solution 
(*.sln) file in the <WINCEROOT>\OSDesigns\<project-name> directory.

Select a solution configuration ( TR4UCONXS ARMVI Release or Debug):

To build a project, choose Build->Build <project-name> from the menu.
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If no errors occur, the build process runs makeimg.exe. which will create a nk.bin 
file in your _FLATRELEASEDIR ( Build -> Open Release Directory in Build Win-
dow). After nk.bin is created, PostMakeImg.bat will run. This batch will create 3 
binaries, patched with a bootheader ( see [CD::\Documentation\bootloader3.pdf] for 
further details).

• nk_ram.nb0 Image will be loaded to RAM and execute.
• nk_rom.nb0 Image will be stored to flash (uncompressed).
• nk_zip.nb0 Image will be stored to flash (compressed).

These files can be downloaded to the device through the standard bootloader in 
many ways ( see 2.3.1. Loading files).

The maximum size of a Windows Embedded CE-image build with this Board-Sup-
port-Package is 95MB. Note that the image will be copied to the end of RAM at 
startup, leaving (RAM-size) - (nk_ram.nb0-size) for use as program and storage 
memory. Windows might not boot on low memory conditions!

Also note that storing flash-images ( nk_rom or nk_zip.nb0) with a size greater than 
16MB might destroy the flashdisk. Either use nk_ram.nb0 or remove the 
IPSM4000-catalog item in this case.

4.3 Downloading the Windows Embedded CE Image
The simplest way to download your Windows Embedded CE Image to the uConXS-
Board is through SD-card.

If you only want to try your CE-Image, just put nk_ram.nb0 on the card.
Create an autoboot.bat-file containing:
display
boot mmc nk_ram.nb0

(File must end with a blank line)
Insert the card and power-up the board. 
display: shows boot bitmap
boot mmc nk_ram.nb0 will copy the CE-image to RAM and boot it.

If you want to store the image permanently, put nk_zip.nb0 on a SD-card, enter the 
bootloader and type:
boot mmc nk_zip.nb0
This will burn the image to flash. Type „fb“ or reset board. 

If you previously stored the registry through Start->Programs->KuK Tools->Store, 
your new CE-Image might hang during boot. Before loading a different image, you 
must erase the registry either with the KuK Tools or with the bootloader-command 
ereg.
If the flashdisk does not exist or was destroyed ( either by using a too large CE-
Image or using another flashdisk-driver-version), the flashdisk gets reformated. 
This might take some minutes and you will probably only see the CE-Image.

4.4 Downloading the Windows Embedded CE Image with Eboot
[please note that we recommend loading files through SD-card or TFTP, 
because Eboot has some limitation. ]
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Eboot is the „Microsoft Bootloader“ for Windows Embedded CE -devices and 
offers a good integration in the Visual-Studio IDE. You may also use the methods 
described in chapter „2.3.1 Loading Files“.
If you want to use an Eboot-interface for downloading images to the uConXS-
Board, you have two options:
• Rename eboot.nb0 ( found at the same directory as nk_ram.nb0) to autoboot.000 

and copy it to a SD, MMC card. After booting, eboot will be started. 
• Use the bootloader to download ebootrom.nb0. This will copy eboot to flash. 

Eboot will be started on next boot.

After Eboot starts, it tries to get an IP-address through DHCP. View Eboot source-
code at <WINCEROOT>\platform\tr4uconxs\src\bootloader\eboot to change to a 
static IP-address.

Open Target->Connectivity Options... and select Ethernet as download.
Press the settings button next to the download-lisbox and wait till an active target 
device shows up. Select this one and press OK, Apply and Close.
After building the image select Target-> Attach Device.
Donwload should start.

4.5 Using Debug-Images
There are two options to connect to a debug-image, which you may build when 
using configuration „TR4UCONXS ARMV4I Debug“.

1. Using DM9000-Ethernetcontroller.
Copy nk_ram.nb0 to a SD-card and create an autoboot.bat-file with this content:

boot mmc nk_ram.nb0 kitl dm9k_base=0xA8300300 dm9k_int=0x01002465

2.) Using USB-Slave as RNDIS-device.
Copy nk_ram.nb0 to a SD-card and create an autoboot.bat-file with this content:

boot mmc nk_ram.nb0 rndis

If you don’t specify a kitl-transport option, debug output will be directed to COM1.

Start the device with the created SD-Card.
Open Target->Connectivity Options... and select Ethernet as transport (download 
set to none, debugger set to KdStub). You must select Ethernet, even if you want to 
use USB as kitl-transport!
Press the settings button next to the transport-lisbox and wait till an active target 
device shows up. Select this one and press OK, Apply and Close.
Select Target-> Attach Device.
Debugger should connect.

If you are using the USB-RNDIS option for the first time, you may have to specify 
a valid usb8023.inf-file and usb8023.sys:
C:\WINCE600\PUBLIC\COMMON\OAK\DRIVERS\ETHDBG\RNDIS-
MINI\HOST\usb8023.inf
C:\WINDOWS\system32\drivers\usb8023.sys
After the network-adapter appears, assign a static IP-address of 192.168.254.2.
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4.6 Creating an image from scratch
1. File-> New Project...
2. Choose Project type: „Platform Builder for CE 6.0“
3. Select „OS-Design“ and press OK.
4. When Windows Embedded CE6.0 OS Design Wizard opens, press Next.
5. Choose TR4UCONXS: ARMV4I as Board Support Package.
6. Follow the instruction of the design wizard..

Note:

Add the RAM-based Registry component (SYSGEN_FSREGRAM) to your solu-
tion.

If a component added is excluded from build (red-cross instead a green check 
mark), you get the reason by pressing the right-mouse-button on that icon and 
choosing „Reason for Exclusion of Item“. 

Sometimes drivers need additional components from the Microsoft Platform-
Builder to function as expected!

• To use a SD/MMC storage card, you have to include the FAT-Filesystem compo-
nent.

SD/MMC: add „SD Memory“ SYSGEN_SD_MEMORY

USB-Slave: add at least one of the USB-Function clients (RNDIS, 
Serial(ActivSync), Mass Storage)  (i.e. Serial: SYSGEN_USBFN_SERIAL).
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